
Advanced Tutorial – Analyze a Skylight Using the Sun & Sky Dome Models 

Prerequisites 

This tutorial is written with the assumption that you have already completed and understand the Beginner 
Tutorials under Help > Beginner Tutorials or in Chapter 3 of the User’s Guide.  This tutorial does not 
therefore repeat all of the basic information about how to start a project, setup the analysis, run the 
raytrace and view the results.  If you have not yet completed the Beginner Tutorials, then please do so 
before you proceed. 

Design Overview 

Photopia includes sun and sky dome “lamp” models for use in modeling daylight collection devices.  
These models are based on the IESNA RP-21 daylight equations that model the absolute illuminance 
from the sun (solar disk) at various altitude angles and the sky for various sky conditions and solar 
altitude angles.  The sky domes include variable luminance values across the hemisphere as described in 
RP-21.  The combination of both the sun and sky dome models produces a total illuminance onto the 
daylighting device area that is intended to match real outdoor conditions.  Keep in mind that real 
conditions can vary widely and the RP-21 equations represent average conditions. 

This tutorial will describe how to use Photopia’s sun and sky dome lamp models for daylighting 
applications through an example.  Given a particular location and skylight geometry, Part 1 of this tutorial 
will walk you through a daylighting analysis of the skylight.  In Part 2, you will learn how to use scripting to 
analyze the skylight for multiple sun locations.  The complete skylight geometry you will use is Skylight 
Tutorial.dxf, which should be located in your C:\Program Files\LTI Optics\Photopia 3\Projects folder.   
 
 

Part 1: Analyze a Specific Sun Position 

Using the Daylighting Calculator 

We will analyze the skylight at noon on June 21, 2009 for a building located in Boulder, Colorado 
(approximate latitude 40°N and longitude 105°W).  The first step is to calculate the sun’s position for this 
location and time. 

1. Use a spreadsheet program such as Microsoft Excel to open LTI Optics Daylighting 
Calculator.xls, located in your C:\Program Files\LTI Optics\Photopia 3\Documentation folder. 

You can utilize this spreadsheet tool by entering values into the light blue cells and reading calculated 
values from the gray cells.  We will use the first tool, titled “Enter Time & Location (Imperial Units).” 

2. Enter 40 for Latitude, 105 for Longitude, 12.00 for Time, and 6/21/2009 for Date. 
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In the gray cells beneath the cells into which we just entered data, notice the updated values for the 
various daylighting metrics.  We will use the calculated Solar Altitude value of about 70 degrees to setup 
the Photopia model. 

3. Enter 14 for Diameter of Tube, which is the diameter of the skylight in Skylight Tutorial.dxf. 

We now also have a value for the Total Input Lumens, which we will later use to calculate the skylight 
efficiency. 

Import the Skylight, Sun, and Sky Models 

4. Start Photopia, start a new project, and save it as 14in Skylight Boulder 6-21 Noon.ray. 

5. This project will be in inches, so make sure the project units are set to inches.  This is indicated 
next to the coordinate readout in the lower left corner of the screen.  You can change the units 
under Settings > Project Settings or by typing the UNITS command. 

6. Under File > Import CAD File > DXF/DWG, navigate to C:\Program Files\LTI Optics\Photopia 
3\Projects to import Skylight Tutorial.dxf.  Click Open and press Enter for the default units of 
inches. 
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Use orbit and zoom to view the skylight.  Notice that there are three layers for the various skylight parts: 
the diffuser lens, the light tube, and the dome.  After noting each layer’s color, we can ensure that the 
surfaces are oriented correctly. 

7. Right click in the CAD view and choose View Style > Show Surface Orientation. 

  
 

The surfaces need to be oriented towards the incident light, meaning that their respective layer colors 
should face the incident light.  For light entering through the top of the dome, traveling through the inside 
of the tube, and exiting through the diffuser lens, it looks like we will need to re-orient all three surfaces. 

8. Select all surfaces and choose Modify > Orient.  Enter R for reverse. 

  
 

Based on the spreadsheet calculation from steps 1-3, we know that we need to use a solar altitude of 
about 70°.  Solar altitude is the angle up above the horizon, so 10° is near the horizon and 90° is directly 
overhead.   We will import the sun and sky dome component for a 70° solar altitude.  To start with a 
matching clear sky situation and sun angle, as well as the sun model being at the correct angle and 
orientation, we will import a “SUNCLRSKY??#X#.CMP” component file, where ?? = the solar altitude 
angle and #X# indicates the size of the sun model in feet. 

9. From a top view, under File > Import Component, choose SUNCLRSKY703X3.cmp.  Enter an 
origin of 0,0,72 so that the bottom of the clear sky dome will line up with the bottom of the skylight 
entrance. 
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A right-side view shows the sun and clear sky models properly positioned relative to the skylight. 

Build a Shield 

We will need to make a large enough shield in the model to prevent the light from the sky dome from 
being counted in the output exiting from the bottom of the skylight.  Thus, the shield should have an 
aperture that allows light from the sun and sky dome models into the skylight, but blocks all other light 
from the daylight lamp models.  The sun/sky component that we imported already includes a shield 
around the top of the sky dome, in red, but we will need to build a shield across the bottom of the dome. 

10. From a front view, choose Design > Reflector: Polyline Based > Revolved. 

a. Enter a lamp center of 0,200 since this is the general area of the sun model and the 
middle of the clear sky dome. 

b. Enter a start point of 7,72 to start the shield at the base of the skylight dome, which is 
where the roof line would start. 

c. Enter 370,72 for the next profile point so that the shield profile extends just past the base 
of the upper shield, blocking all of the sky dome light from exiting anywhere but through 
the skylight. 

d. Press enter again to end the profile. 

e. Choose 48 for the number of revolve segments. 
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Since the new shield reflector was automatically created in an REFL-Main layer, we need to move it onto 
the layer that the rest of the shield is on. 

11. Click the new shield to select it.  Under General in the property control, change the Layer to 
REFL-Shield. 

Setup the Raytrace 

12. Before the analysis is started, first assign materials under Edit > Design Properties.  Under the 
Reflective tab, assign Alanod Miro 4 Silver to REFL-Light Tube.  The REFL-Shield layer should 
already be assigned with Generic ZERO0000 since this layer was imported with the component. 

 
 

13. Under the Transmissive tab, assign Cyro Satin Ice to TRAN-Diffuser Lens and Generic 
POLYCRB to TRAN-Dome.  Click OK. 
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14. Then, under the Photometric Report tab in Analysis > Specify Photometric Output, set the 
horizontal angles of the candela distribution to (0(15)180) and keep the default of (0(5)90) for the 
vertical angles.  Set the Luminous X and Y Dimensions to 14 each for the diameter of the skylight 
opening, and the Z Dimension to 0 since the skylight opening into the room has no luminous 
height.   

 
 

15. Under the Illuminance tab, define an illuminance plane that is 40’ x 40’, 10’ below the skylight 
opening, using 100x100 columns and rows.  Click OK twice to exit the Photometric Output dialog. 
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16. Under Analysis  > Specify Raytrace Settings, change the Initial Source Rays to 100,000,000 
since a lot of the generated rays will be absorbed by the shield, not even entering the skylight.  
Uncheck the Enable Ray Emanation Shadowing box since it is unnecessary for this application 
and causes a slower raytrace.  Also, type /slotlamp10000 into the Additional Raytrace 
Parameters to ensure a good distribution of rays emanating from each of the many sky dome 
“patches.” 

 
 

Analysis Results 

17. Choose Analysis > Begin Analysis to run the analysis.   

18. View output data by choosing View > Candela Distribution > Polar Plot, View > Illuminance > 
Shaded Plot, and View > Photometric Report. 
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The efficiency (LOR) shown in the Photopia report will be the ratio of the lumens exiting the skylight 
divided by the total lumens produced by the sun and sky dome models.  The total lumens produced by 
the sun and sky dome models is very large compared to the total number of lumens that are actually 
incident onto the skylight itself.  A more appropriate measure of the skylight efficiency is the ratio of the 
lumens exiting the skylight divided by the number of lumens incident onto it.   

19. To calculate the skylight efficiency, find the total number of lumens exiting the skylight under the 
Lumens Exiting System section of the Photometric Report.  It should be a value close to 7438 
lumens. 

20. Take that value divided by the number of lumens incident onto the skylight, which we calculated 
in steps 1-3 to be 11,138 lumens.  So the efficiency is about 66.8%. 

 
 

Part 2: Analyze Several Sun Positions with Scripting 

To simulate complete daily data with a range of solar altitudes, you must import the sun/sky component 
and run a raytrace for each solar altitude you wish to run.  Instead of manually doing this work, we can 
run a script for Photopia to automatically run each raytrace, one after another, at a convenient time such 
as overnight. 
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Setting up a Base Project 

We will first setup a base project that will be used to import each solar altitude component.  Since the 
skylight geometry and raytrace settings are already setup in the file from Part 1, we will make a copy of 
that file to start with.  

21. Make a copy the .ray file from Part 1, 14in Skylight Boulder 6-21 Noon.ray, and change the 
copied filename to 14inSkylight.ray. 

Photopia scripts do not work with filenames or file paths that include spaces, so make sure its full file path 
has no spaces.   

22. If the new .ray file is saved in a file path with spaces, move the file to a different folder with no 
spaces in the entire file path, creating a new folder if you wish.  For example, move the file to 
C:\Photopia\SkylightTutorial. 

To turn the file into a base file for importing any solar altitude component, we need to delete the project’s 
current sky and sun models. 

23. Open the copied file, 14inSkylight.ray. 

24. Delete the sun model, the sky dome model, and the shield dome.  All three of these elements are 
included in each component file, so we will setup the script to import each component file for each 
solar altitude.  Do NOT delete the lower portion of the shield that masks across the bottom of the 
sky dome because this shield is NOT included in the component files. 

 
 

25. Save and close the project. 

Writing a Script 

Scripts can be stored in any location and they end with a .script extension.  They are a text file that you 
can edit in notepad or any other plain-text editor.  Each line contains a command.  A semicolon 
represents the end of a command and is equivalent to a space or enter in Photopia's command line 
interface. 

26. Open a new file in a text editor such as Notepad.  Save the file as 14inSkylight10-90.script. 



 10 Advanced Tutorial – Analyze a Skylight 

 
 

27. Enter the following text into the file.  The description of each text line is included below in red for 
your reference, but do not enter this descriptive text into your script file. 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Opens the specified file using the full file path.  The file path 
cannot include spaces. 

Application.SuppressUserPrompts; 

Suppresses pop-up dialogs.  This should be issued after every 
OpenProject command or else the script may be stopped due to 
a pop-up dialog box which waits for user input. 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight10.ray; 

Saves the project as a new name.   We will start with the 10° 
solar altitude. 

importobject;SUNCLRSKY103X3.cmp;0,0,72; 

Imports the specified component file at the specified location. 

RAYTRACE;NO; 

Initiates a raytrace analysis.  The “NO” must be included to 
indicate that the raytrace should not run in a separate thread, 
which would cause the raytrace and the script to get out of sync. 

Application.SaveProject; 

Saves the file. 

Application.CloseProject; 

Closes the file. 

Application.FlushMessages; 

Forces Photopia to wait for a project to completely close before 
moving onto the next command.  Should be issued after every 
CloseProject command. 
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28. Copy and paste the text entered from step 27 and alter the angle value (in both the saved 
filename and the component import command) for each solar altitude you want to run.  Below is 
the text for solar altitudes 20° through 90°.  Note that you can only use solar altitudes in 
increments of 10° since that is what is included in the current Photopia library. 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight20.ray; 

importobject;SUNCLRSKY203X3.cmp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight30.ray; 

importobject;SUNCLRSKY303X3.cmp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight40.ray; 

importobject;SUNCLRSKY403X3.cmp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight50.ray; 

importobject;SUNCLRSKY503X3.cmp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight60.ray; 

importobject;SUNCLRSKY603X3.cmp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight70.ray; 

importobject;SUNCLRSKY703X3.cmp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight80.ray; 

importobject;SUNCLRSKY803X3.cmp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

Application.OpenProject<C:\Photopia\SkylightTutorial\14inSkylight.ray; 

Application.SuppressUserPrompts; 

Application.SaveAsProject<C:\Photopia\SkylightTutorial\14inSkylight90.ray; 
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importobject;SUNCLRSKY903X3.cmp;0,0,72; 

RAYTRACE;NO; 

Application.SaveProject; 

Application.CloseProject; 

Application.FlushMessages; 

 
 

Run the Script 

Now that the base project is setup and the script is written, choose a time to run the script when you will 
not necessarily need the memory on your computer, such as overnight.  

29. Open a new file in a text editor such as Notepad.  Save the file as 14inSkylight10-90.bat. 

30. Enter Photopia/script=C:\Photopia\SkylightTutorial\14inSkylight10-90.script in this Windows Batch 
file. 

31. Place this batch file in the same directory as Photopia.exe, which is typically C:\Program Files\LTI 
Optics\Photopia 3\EXE\. 

32. Double click the batch file to run the script. 

All commands in your script will now run and your raytraces will be completed one after another.  When 
you’re ready to work again the next morning, you should find all the new 14inSkylight##.ray files saved on 
your computer in the directory you specified, C:\Photopia\SkylightTutorial\ in this case, and you can open 
each of them to view their results. 


