
Beginner Tutorial 2 – Analyze a Luminaire 

Once a 3D luminaire model is inside Photopia and its materials are assigned, it is ready to be analyzed.  
Photopia allows you to specify a range of settings that control the analysis process and also dictate the 
type and format of the photometric output produced.  The following sections lead you through the details 

of specifying the photometric output and raytrace settings.  Before starting, choose File > Open and find 
SAMPLE1.DWG in the C:\Program Files\LTI Optics\Photopia 3\Projects folder, if it is not already open. 

Photometric Output 

1. Select Analysis > Specify Photometric Output from the main menu.  This screen allows you to 
select the type(s) of output Photopia will generate.  Your choices include a Photometric Report 
and Illuminance on a Plane.  Additionally, you can specify whether the photometry will be Absolute 
or Per Thousand Lamp Lumens.   

 
 

Absolute photometry is based on the lamp lumens specified in the Design Properties screen (the rated 
lamp lumens).  Photometry reported per thousand lamp lumens is scaled so 1000 total lumens were input 
into the luminaire.  If the SAMPLE1 luminaire were photometered using per thousand lamp lumens, it 
would be assumed that each of the three lamps generated only 333.33 lumens.   

2. For this tutorial, choose Photometric Report and Illuminance on a Plane for the output types, and 
Absolute for the output scaling. 

 

Photometric Report  

3. Select the Photometric Report tab to specify the details of your photometric report.  This screen 
allows you to choose a report type, photometric type, the horizontal and vertical angles in the 
distribution, test distance, decimal precision, and the photometric center.  The following sections 
provide a brief description of each of these items. 
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File Format 

Photopia will create a standard format photometric file as part of its output.  Photopia always creates an 
IES file that is stored with your project files in the folder you specified, using the name of your project as its 
filename prefix.  In this example, Photopia will create a file named SAMPLE1.IES.  Photopia can also 
create a EULUMDAT (European standard) or TM14 (British standard) format file if you select either of 
them in the File Format list box.  The filenames will be SAMPLE1.ELX for the EULUMDAT file and 
SAMPLE1.T14 for the TM-14 file. 
 

Report Type 

The specific format of the photometric reports generated by Photopia can be tailored to the needs of the 
specific type of luminaire you have.  Photopia generates reports appropriate for indoor luminaires, 
floodlight luminaires, and roadway luminaires.  Since the SAMPLE1 luminaire is a fluorescent troffer, we 
will leave the default of indoor report type. 
 

Photometry Type 

The photometry type you select determines the orientation of the horizontal and vertical angles in the 
candela distribution as well as the constraints on these angles (as a matter of convention) set forth by the 
Illuminating Engineering Society of North America (IESNA). Indoor luminaires can be photometered with 
either Type A or Type C photometry. These photometric types define spherical coordinate systems with 
the poles of the coordinate system directly below (at nadir) and directly above (at zenith) the luminaire. 
The IES recommends that indoor luminaires be photometered as Type C. For more details about 
photometric types and the horizontal and vertical angles associated with them, see Chapter 6. 
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Type A & C Coordinate System 

 

Specifying Horizontal and Vertical Angles 

The horizontal and vertical angles determine the exact mesh or web of points to be sampled in the 
spherical coordinate system. Both the horizontal and vertical angles are specified as a list of angles using 
the following syntax: Start Angle (Angular Increment) Stop Angle. Commas are used to separate individual 
angles or ranges of angles, thus (0,5(10)85,90) is the same as (0,5,15,25,35,45,55,65,75,85,90). Spaces 
are not allowed. You can choose pre-defined angle sets from the lists provided, or define your own by 
typing them in using this convention.  

4. Select 0(22.5)90 for the horizontal angle set and 0(5)90 for the vertical angle set.  

The complete range of the horizontal angles runs from 0° to 360°. We chose 90° as a stopping point since 
our fluorescent luminaire is quadrilaterally symmetric. This means that a single quadrant of photometric 
data completely describes the photometric distribution of the luminaire. All other quadrants of data are 
derived from the first quadrant by assuming symmetry about the XZ and YZ vertical planes running 
through the luminaire’s center.  

The complete range of vertical angles runs from 0° to 180°. We chose 90° as a stopping point since our 
luminaire is a direct luminaire (it directs all of the light downward).  No symmetry is assumed with vertical 
angles. If we had a completely indirect luminaire (one that directs the light toward the ceiling), then we 
would have selected vertical angles ranging from 90° to 180°. If we had a direct/indirect luminaire (one 
that directs light up and down), then we would have selected an angle set ranging from 0° to 180°. 
 

Test Distance 

The test distance refers to the distance from the photometric center to the photocell used to measure the 
amount of light in a given direction.  Luminous intensity distributions (candela distributions) can vary 
depending on the test distance used.  In general, candela distributions stabilize and approach a constant 
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shape if the test distance is greater than five times the maximum dimension of the luminaire. Thus, for the 
SAMPLE1 luminaire, which is a 2’ x 4’ troffer, keep the default of 20 feet. 
 

Decimal Precision 

The decimal precision refers to the number of decimal places that will be written to the photometric file.  
For most luminaires, two decimal places will suffice.  However, if you have a low output luminaire, such as 
an emergency luminaire where the expected candela values are all quite low, then you may want to 
choose a higher number for the decimal precision to obtain the proper resolution in your calculated data.  
Keep the default of 2 for this tutorial.   
 

Photometric Center 

The default value for the photometric center is obtained from the luminaire CAD file, as described 
previously in the section on importing the luminaire CAD file.  If you wish to change the default photometric 
center, then enter the desired location in the cells provided.  For this troffer, the photometric center should 
be located in the aperture of the luminous opening.  In this drawing, this location is at a Z height of –3 
inches.  

5. So enter a Z value of –3 and leave the X and Y values both at 0 for this tutorial.   
 

Luminous Dimensions 

Photopia uses the luminous dimensions of the luminaire and the calculated candela values to estimate 
average luminaire brightness values for certain viewing angles. By default Photopia uses the physical 
extents of the luminaire for these dimensions. However, there are many cases where this assumption is 
not correct, and you may therefore enter the dimensions that should be used. Any recessed luminaire 
such as a downlight or the troffer in our tutorial are examples of luminaires for which you would want to 
modify the dimensions. In particular, you need to change the luminous height (Z dimension) to 0 since the 
sides are not luminous.   

6. Uncheck the checkbox for User Physical Extents from CAD Model and enter a Z value of 0.   
 

Illuminance on a Plane 

Once you have entered all of the photometric report information, select the Illuminance tab. 
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Photopia allows you to specify as many illuminance planes as you like. For each plane you must define its 
location and grid density. Additionally, you can deactivate planes you do not wish to participate in 
calculations.  

7. We will specify only one plane for this tutorial, so enter a 1 into the Number of Planes cell. 

Illuminance planes are defined relative to the absolute location and orientation of the luminaire in the CAD 
drawing. The SAMPLE1 luminaire is centered on 0, 0, 0 and has its three lamps running along the Y-axis 
in the X-Y plane. The light is directed in the -Z direction. This is the orientation the luminaire should have 
in order for the horizontal and vertical angles, specified in the photometric report, to have meaning. For 
more details on the construction of a luminaire in the CAD program, see Chapter 4. 

Illuminance planes are defined by four corner points, three of which you must provide, as shown in the 
following illustration. For more information on illuminance planes, see Chapter 6. 
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Illuminance Plane 

 

The illuminance plane for this tutorial will be 20’ x 20’ in size, centered 8 feet below the luminaire. The grid 
density will be 0.25’ x 0.25’. With this information you can now define the illuminance plane: 

8. Select the Illuminance Plane 1 from the list.  

9. Click the Define Plane button.  Photopia displays an Illuminance Plane pop-up screen.  

10. Edit the Description by typing in 20’ x 20’ Plane, 8’ Below. 

11. The location of the plane is specified by 4 corner points.  The descriptions of these points, for 
example, Lower Left Corner, refers to the location of the point you wish to view on a page.  Be 
aware of the units for the illuminance plane coordinates.  They are shown in the bottom left hand 
corner of this screen.  Assuming the units for this tutorial are in feet, enter -10, -10, -8 for the 
Lower Left Corner point.   

12. Enter 10, -10, -8 for the Lower Right Corner point. 

13. Enter -10, 10, -8 for the Upper Left Corner point. 

14. The Upper Right Corner point will be calculated automatically. 

15. Enter a Column Spacing of 0.25 feet and the Number of Columns cell will automatically be filled 
out. 

16. Enter the same value into the Row Spacing.  The coordinate specifications should be as shown 
here. 
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17. Once you have all of your values properly entered, click the OK button on the Illuminance Plane 
pop-up window.  Once you have finished with all of the photometric output specifications, click the 
OK button. 

Note that you will be able to see your illuminance plane in the CAD view inside Photopia.  So it should be 
clear if you did not enter your coordinates properly.  If your plane looks like it is the wrong size and in the 
wrong location, then check the units of the plane coordinates and ensure you entered numbers 
appropriate for that unit.   
 

Specifying Raytrace Settings 

Select Analysis > Specify Raytrace Settings from the main menu. This screen allows you to set the 
parameters that control the raytrace and the display of the results. The following sections provide a brief 
description of each of these items. 
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Initial Source Rays 

The Initial Source Rays refers to the total number of rays that will be emitted from all of the light sources.  
Thus, if 3,000,000 initial source rays were specified, then 1,000,000 rays would emanate from each of the 
three lamps in the SAMPLE1 luminaire.  In general, the more rays specified, the more accurate your 
photometric output.  However, the output becomes asymptotic at some point.   

It is generally the case that the resolution of your output defines the level of the raytrace you require.  A 
single value like luminaire efficiency can be calculated accurately (to the point at which it is not changing 
any further) in 50,000 rays.  Accurate candela distributions can take anywhere from 2,500,000 to 
5,000,000 rays, depending on the number of lamps in the luminaire and the size of the angular zones in 
your candela distribution.  A high-resolution image of an illuminance plane using a grid density of 100 x 
100 or more, could take 10,000,000 rays or more to produce a smooth looking image.   

When a raytrace analysis is done with too few rays, the results are scattered and spiky when the ultimate 
result is smooth and contained.  This behavior comes from the nature of the calculations, where the rays 
are randomly emanated from light sources and scattered upon reflections.  The emanation and scattering 
directions are driven by probabilities, meaning that only after many rays do the patterns embedded in the 
probabilities become evident.  The more rays, the more the final patterns emerge.   

A luminaire such as the SAMPLE1 design will show relatively smooth output at the level we have specified 
using 2,500,000 rays.  You can therefore keep the default number of rays. 
 

Number of Reactions 

The number of reactions traced determines how far a ray will be followed before it is disregarded.  A 
reaction is defined to be an intersection with a surface.  For surfaces that are purely reflective, one 
reaction reflects an incident ray into its resulting direction.  For surfaces that are transmissive, one 
reaction intersects the surface, transmits, and reflects a ray.  For light re-entering a fluorescent lamp, one 
reaction is necessary to get into the lamp (and reflect a ray on the outside), and another reaction is 
necessary to get out of the lamp.  However, the ray trying to leave the inside of the lamp will go through a 
transmissive surface as well, thus, both transmitting a ray and reflecting another ray inside the lamp.  
Keep the default of 25 reactions for this tutorial. 
 

Ray Emanation Shadowing 

The last item in the Basic Raytrace Parameters section controls the ray emanation shadowing feature in 
Photopia. Lamps having surfaces that block the view of each other from an outside viewpoint, (e.g. a 
compact fluorescent lamp with its multiple tubes or the filament support structure in a quartz halogen 
lamp) need to have special checking enabled in the calculations to ensure light does not pass through any 
surfaces which shade other surfaces.  

18. Turn this option off for this tutorial since our lamps do not have any self shadowing. 
 

Advanced Raytrace Parameters 

These will not be used in this tutorial, so keep the default settings. 
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Analysis Update Frequency 

Under the Display tab, the analysis update frequency specifies how often all of the output you are viewing 
is updated as the raytrace process proceeds. Keep the default value of 10% for the tutorial and you will 
get to view your calculated output as soon as 10% of the analysis is completed. You can then observe 
how the output changes and iterates every 10% toward a smooth solution as more rays are traced. 
 

Ray Posting to Geometry View 

Photopia will write 3D rays from the raytrace to a DXF file so that you can either view them in your CAD 
program or within Photopia.  You can specify the number of rays and the length of the last ray segment 
after it exits the luminaire.  Check the Add 3D Rays to Project checkbox if you want to see the rays 
imported into Photopia.  The rays will be segregated by different CAD layers depending on the lamp from 
which they emanated and their reflection number.  For this tutorial we will leave this option turned off.   
 

Running an Analysis 

Now that we have completed all of the necessary steps preparing our analysis, we can start the raytrace.  

19. Select Analysis > Begin Analysis from the main menu.  

On the program’s bottom toolbar you can see the progress of the calculations.  After the first analysis 
update, you will see an estimated time of completion.  While the analysis is running, you can terminate the 

analysis at any time.  To do so, select the Analysis > Terminate Analysis from the main menu.  A 
terminated analysis cannot be resumed and will restart from the beginning. 
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Viewing the Photometric Output 

While the analysis is running, we are able to view the calculated output.  The first view of the output will be 
available after the calculations reach 10% (our specified update frequency).   

Viewing the Photometric Report 

Begin with the photometric report.   

20. Select View > Photometric Report from the main menu. Photopia displays the formatted report 
generated for the SAMPLE1 luminaire.  You can scroll through the report by using the up and 
down arrow buttons located on the right hand side of the screen.  Chapter 6 provides more details 
on the data in the report. 

 

Viewing the Candela Distribution Polar Plots 

21. To display a polar plot of the candela values, select View > Candela Distribution > Polar Plot 
from the main menu.  To watch the polar plots change at each update of the results, bring up the 
polar plot at the start of the raytrace.   

 
 

Viewing the Illuminance Plane Data 

Photopia gives you the option of viewing the illuminance plane data in several different ways.  You can 
view the data as text in tabular form, a contour plot, a gray-scale shaded plot, or a false color plot.  You 
can also view the data directly on the illuminance plane shown in the CAD views.   

22. To view the data in text form, select View > Illuminance > Text from the main menu.   

23. To view the data as a shaded plot select View > Illuminance > Shaded Plot.  Next, select the 
illuminance plane name and click the OK button. 

24. To view the shaded plot in the CAD view, click on the CAD view for the project, then right click 

your mouse while in this view and select Zooming > Zoom Extents from the pop-up menu.  Then 
pick the edge of the square defining the illuminance plane with your mouse (left-click).  It will be 
shown in light red when it is selected.  The properties of the illuminance plane will be shown in the 
property control at the right hand portion of the screen.  Click on the property for Display Plot 
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under Display and change the default value of False to True.  Then press Esc on your keyboard to 
de-select the illuminance plane.  You will now see the shaded plot.   

25. Change the plot settings by selecting Settings > Plot Settings from the main menu.  Make sure 
the Plot Grid Lines are off for both the X and Y-axes and also set the label frequency for both axes 
to 8.   

26. Rotate your view of the CAD model and illuminance plane by right clicking your mouse and 

selecting Dynamic Views > Orbit from the pop-up menu.   

 
 

Printing the Output 

You can print any of the output views by clicking in the view to make it the active view, and selecting File > 

Print Active View from the main menu or by selecting to print from the right click pop-up menu within the 
CAD view.  You can also save the views to a BMP file or save any vector based view to a DXF or DWG 
file.   


