Advanced Tutorial – Designing a Collimator for an LED Source
This tutorial demonstrates importing an LED with integrated optics and designing a collimator lens around
it, utilizing the trimming and half arc features in Photopia’s polyline reflector. It is a good idea to complete
the beginner tutorials before attempting this advanced tutorial, since many of the more basic functions and
concepts are not explained in this tutorial.
The collimator design parameters for this tutorial will be the following: a 10 degree full beam angle (+/- 1°),
a 20mm maximum height, and a 20mm maximum diameter. We will use the Lumileds Rebel as the
source and acrylic as the lens material.
Note that this tutorial uses millimeters as the units. You can change a project’s length units by choosing
Settings > Project Settings.

Import the Lamp
LED’s with integrated optics are modeled in a more complex way in Photopia than traditional lamps. The
added complexity allows Photopia to simulate exactly how light emits from the LED chip, and how that
light interacts with the LED’s integrated optics, such as a hemispherical lens. Because these lamp models
have extra elements, they must be imported as component files, which include the chip core as a lamp
model along with refractive and reflective layers that make up the optics around the chip. See Type 3
Source Models in Appendix B of the User’s Guide for more information.
1. Start a new project and choose File > Save As to give it a name such as LED Collimator.
2. Choose File > Import Component and then browse for the LED component file named LXMLPWC1-0050.cmp, which is the white Lumileds Rebel. Insert the component at 0,0.

Construct the Collimator
We will start by building a concave entrance to the collimator around the LED dome. Using an entrance
surface that is basically parallel to the LED dome will allow the light to enter the collimator without
refracting yet.
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In order to make this entrance surface, we can utilize Photopia’s automatic trimming and half arc features
that are associated with polyline reflectors. We will start by drawing a polyline reflector profile in the form
of a horizontal line rather than an arc, and then add arc properties to that line segment, or reflector
section. The start of the reflector section should be at the point where you will want the base of the arc to
start. The end of the reflector section should be either the center of the arc (which is on the axis of
revolution) or any point past the center, keeping the line horizontal. You may choose any point past the
center because Photopia will automatically use a trimmed version of the reflector section, trimmed at the
axis of revolution, to construct the revolved arc. It can be more convenient to choose a point that is past
the center because if you later choose to adjust the start point of the reflector section (for example, if a
different size LED is to be substituted into this design), its length will likely still be long enough to prevent a
hole from appearing in the middle of the revolution.
After drawing the polyline reflector as a horizontal line, we will use Photopia’s half arc feature to turn the
line into a revolved arc. You can make any section of a polyline reflector into an arc by entering any nonzero value for the Angular Extent in Reflector Design View. Doing so will, by default, create a full arc from
the section’s start point to its end point (or trimmed end point if the axis of revolution is crossed) using the
specified angular extent. For arc profiles that cross the axis of revolution, it is convenient to change the
full arc into a half arc, which can be changed in Reflector Design View for the end section of any polyline
reflector. A half arc that crosses the axis of revolution will always be constructed so that the revolved
result is a full arc at the specified angular extent.
3. Under Settings > Layers, create a new layer named REFR-Collimator with a color such as cyan.
Set this new collimator layer to be the current layer and click OK.
Since our current layer is a refractive layer, any reflector we create will automatically behave as a
refractor. This allows us to use the reflector tools to create refractors.
4. From a front view, choose Design > Reflector: Polyline Based > Revolved.
a. Press Enter to accept the default lamp center of 0,0.
b. Enter a start point of 1.5,0 in order to keep the base of the collimator close to the LED
while allowing some room for tolerance between the two.
c.

Enter -1.5,0 for the next profile point. Recall that we will later add arc properties to this
segment.

d. Press enter again to end the profile.
e. Choose 72 for the number of revolve segments.
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The new refractor segment will be hard to see, but if you orbit in CAD view you should be able to find its
cyan lines. To turn the new refractor segment into a revolved arc:
5. Select the new refractor by clicking on it, and then choose View > Reflector Design.
6. Change the segment’s Angular Extent to -180 and Arc Type to Half.

7. Enter a Name for the refractor piece in the property control such as Entrance.
Next we will build a small horizontal base for the collimator, which will allow a location for mechanical
features to be added later on. This base will also allow some extra space between the LED and the outer
surface of the collimator, which means the size of the source relative to the outer surface is smaller
(closer to a point source), which creates less spread and maintains more light control. We can start with a
base of 1mm length and adjust later if the collimator diameter ends up being far from the maximum value
of 20mm.
8. From a front view, choose Design > Reflector: Polyline Based > Revolved.
a. For polyline reflectors, the specified lamp center only determines the surface orientation
(not the reflector shape, as with aiming based reflectors). To ensure that this surface that
is in line with the lamp center will be oriented correctly, we can enter an artificial lamp
center. Since this base surface should be oriented upward, enter an artificial lamp center
of 0,10. (Note that refractor surfaces should always enclose a 3D space and be oriented
outward from that space.)
b. Enter a start point of 1.5,0 so that the collimator base surface starts where the entrance
surface left off.
c.

Enter 2.5,0 for the next profile point to make a 1mm long base surface for now.

d. Press enter again to end the profile.
e. Choose 72 for the number of revolve segments.
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9. You can ensure that the surface is oriented correctly, as shown below, by right clicking in CAD
view and choosing View Style > Show Surface Orientation, and then using orbit. You can then
return to the original view style by selecting Wireframe.

10. Deselect current selections if any, and then click on the new base surface to select it. Enter a
Name in the property control such as Base.
Next, we can link the base surface profile to the entrance surface profile. Even though we constructed the
two to have the same start point, if you later decide to change the diameter of the entrance (for example, if
a different size LED is to be substituted into this design), the base surface will automatically adjust if we
link it to the entrance surface. Since the two profiles have the same start point, we will need to link to
Same Start rather than the default, End to Start.
11. Click the base surface to select it. Under Start & Extent in the property control, change Linkage
Corner to Same Start. Then change Start Linkage to Entrance.
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Next we will build the outer surface of the collimator, called the TIR (total internal reflection) surface. We
will design this surface so that the light that is directed onto it from inside the collimator will totally internally
reflect and be directed straight downward.
12. From a front view, choose Design > Reflector: Aiming Based > Revolved.
a. Press Enter to accept the default lamp center of 0,0.
b. Enter 2.5,0 for a start point at the end of the base profile.
c.

Enter -60 for the reflector extent, in degrees. This is a good extent to start with, and we
can adjust it later if the collimator’s size constraints are not met.

d. Enter 0 for the aiming of the first section, in degrees.
e. Enter 0 for the aiming of the last section, in degrees.
f.

Press Enter for the default angle increment of 5 degrees even though this value will not
be used since our aiming range is from 0° to 0°.

g. Enter 72 for the number of revolve segments.

13. Deselect current selections if any, and then click the new TIR surface to select it. Enter a Name
in the property control such as TIR.
Notice that the resolution of curve is rather course towards the end of the profile. Since we are designing
a smooth surface, it should be defined by a tighter curve resolution in order to give more accurate results.
The curve resolution setting is an angle input so that every specified number of degrees, a new segment
is drawn.
14. Under Section/Profile in the property control, change the Curve Resolution to 1, in degrees.
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The TIR surface is automatically oriented toward the lamp center, as you can see by right clicking in CAD
view and choosing View Style > Show Surface Orientation. In this case, that orientation is incorrect
since it is the outer surface of a refractor. Refractor surfaces should always enclose a 3D space and be
oriented outward from that space.
15. Click the TIR surface to select it, choose Modify > Orient, and enter R for reverse. Now the TIR
surface should be oriented correctly, as shown below.

Next, we can link the TIR surface profile to the base surface profile. Again, even though we constructed
the TIR profile to start where the base profile ended, if you later decide to change the diameter of the
entrance or the base (for example, if a different size LED is to be substituted into this design), the TIR
surface will automatically adjust if we link it to the base surface.
16. Click the TIR surface to select it. Under Start & Extent in the property control, change the Start
Linkage to Base.
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17. In CAD view, hover your mouse over the end of the TIR surface profile to check if it meets the
size requirements at this time. The end is at about (9.3,-16.2), so it does currently meet the
20mm height max and 20mm diameter max. If we make changes to the any of the profiles, we
will need to confirm the size again at that time.
Now we can draw the rest of the collimator by creating the exit surface.
18. From a front view, choose Design > Reflector: Polyline Based > Revolved.
a. Again, for polyline reflectors, the specified lamp center only determines the surface
orientation. To save a step later on, we can use an artificial lamp center in order to orient
the surface of the exit surface correctly from the beginning. Since the exit surface should
be oriented downward (not upward toward the actual lamp center), enter an artificial lamp
center of 0,-100.
b. Click a start point that is close to the end of the TIR surface profile on the right side.
c.

Hold the Shift key to draw a horizontal line and click the next profile point so that it is close
to lining up vertically with the start of the TIR surface profile on the right side. This section
will be the exit surface for the light internally reflecting from the TIR surface. (Note that
since the light internally reflecting from the TIR surface will be directed straight downward,
it will be perpendicular to this exit surface and so will generally not refract upon exit.)

d. Click the next profile point vertically above the previous one, about 2/3 of the way up the
collimator height. This section will be the shaft leading to the center lens. We will later
adjust the height for the most ideal location of the center lens.
e. Hold the Shift key to draw a horizontal line and click the last profile point so that it is close
to lining up vertically with the start of the TIR surface profile on the left side of the
collimator. We will again utilize automatic trimming and half arc features to add arc
properties to this section, and it will become the center lens.

f.

Press enter to end the profile.

g. Choose 72 for the number of revolve segments.
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19. Deselect current selections if any, and then click the new exit surface to select it. Enter a Name in
the property control such as Exit.
20. Link the exit surface to the end of the TIR surface by selecting TIR for Start Linkage under Start &
Extent in the property control. Now the exit surface profile starts exactly where the TIR surface
profile ends, and if we make any changes to the other profiles, the exit surface will adjust its start
point accordingly.
21. In Reflector Design View, change the End section of the exit surface profile to have an angular
Extent of -120 degrees and an Arc Type of Half. Now the end section should become a revolved
arc surface and can behave as the center lens. We can start with this arbitrary angle and we will
later refine it.

22. Also in Reflector Design View, change the Angle of the second section to 91 degrees. This is a
typical draft angle for the shaft. Ensure that the Angles of the Start and End sections are both at
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180 degrees. (They should already be at 180° if the Shift key was held down to draw these
sections.)

Adjust the Center Lens Location
The location of the center lens is rather arbitrary at this time, but there is an ideal location. The center
lens should be placed so that most of the light from the LED will either be controlled by the TIR surface or
by the center lens, without allowing light to miss both surfaces and without the center lens intercepting the
light that reflects from the TIR surface. We will now calculate that ideal location.
23. Under Settings > Layers, create a new layer named Construction with a color such as red. Set
this new construction layer to be the current layer and click OK.
24. Use the Draw > Line command to draw a line from 0,0 (the LED center) through the end point of
the TIR surface profile. This is the boundary angle of the light that is expected to interact with the
TIR surface. If the center lens is to capture all light that does not interact with the TIR surface,
then the base of the arc needs to start anywhere along this line.

25. Use the line command again to draw a line from 2.5,0 (the start of the TIR profile) to 2.5,-20 (a
point directly below the start point). This is the boundary line for light reflecting from the TIR
surface, meaning that if part of the center lens or shaft is to the right of this line, that part will
intercept some of the light that reflects from the TIR surface, perhaps creating an artifact in the
light pattern.
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The ideal location of the base point of the center lens is a point on the diagonal construction line that is to
the left of the vertical construction line. We will also need to make sure the entire shaft wall is to the left of
the vertical construction line so that the shaft surface does not intercept light that reflects from the TIR
surface. It is also better to locate the center lens further from the LED so that the relative size of the
source is smaller (closer to a point source), which creates less spread and maintains more light control.
Given these constraints, we can pick a precise location for the center lens to start with. Note that since
this calculation is based on a perfect point source, we may need to adjust this location later.
26. Select the exit surface and adjust the Length values of its profile in Reflector Design View in order
to make the shaft profile start to the left of the vertical line and the center lens start at a point on
the diagonal line. Achieve this by using Lengths of 7 mm for the Start section and 12 mm for the
second section. (Note that it is not necessary to adjust the length of the End section because the
automatic trimming will account for the new section location.)
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Setup the Materials and Output
27. Under the Refractive tab of Edit > Design Properties, assign Generic ACRYLIC1 to the REFRCollimator layer. Note that you will also see some layers that already have materials assigned to
them. These are the LED layers that were imported with the component and they are already
setup correctly for the LED. Click OK.

28. Choose Analysis > Photometric Output Specification and go to the Photometric Report tab.
Change the Horizontal angles to 0 since this is an axially symmetric design. Change the Vertical
angles to 0(1)180. We will use a small angular increment because we will be focusing the light
into a small beam angle, and we will use a range from 0° to 180° since there will be a small
amount of light that escapes to angles above 90° and we should account for that light. Then
change the Photometric Center Z coordinate to -10 mm.

11

Advanced Tutorial – LED Collimator

29. Under the Illuminance tab of Photometric Output Specification, create an illuminance plane 3m x
3m, 1m below the collimator. Click OK in both the Illuminance Plane window and the Photometric
Output Specification window.

Adjust the Center Lens Shape
Now that the collimator is constructed and the materials and output settings are ready, we can work on
aiming the collimator’s control of the light. The TIR surface was automatically created to totally internally
reflect the light at the angle we specified, straight down, and so we won’t need to adjust its aiming at this
time. However, the central lens was not automatically created to aim light and so we will now manually
adjust it to aim the light that refracts through it to exit straight down. The most straightforward way to view
and adjust the current refraction of the center lens is to use a polar array of lasers and view the 3D rays
that they produce.
30. Under Settings > Layers, turn all of the LED layers Off using Shift and Ctrl to select multiple
layers. You can identify the LED layers by the “LXML-PWC1” text in the layer name.
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31. From a front view, add a laser by choosing File > Import Lamp and browsing for LASER.ldf.
Enter a lamp insertion point of 0,-0.1 since we will be arraying around 0,0.
32. Use zoom and orbit to locate the new laser model, which is simply modeled as a luminous circle.

33. The laser is currently much too large for the analysis that we want to do, so select it and use
Modify > Scale to scale it by 0.01 around its center, 0,-0.1.
34. Select the laser (you may have to zoom in to locate it) and, from a front view, choose Modify >
Array.
a. Enter P to specify a polar array.
b. Enter 6 for the number of items in the array.
c.

Enter 28, in degrees, for the angle to fill.
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d. Enter 0,0 for the center point of the array.

35. Under Analysis > Specify Raytrace Settings, change the number of Initial Source Rays to
250,000 for a quicker run and the Number of Ray Reactions to 2 to focus on only the initial
refraction through the center lens.

36. Under the Display tab of Specify Raytrace Settings, check the box to Add 3D Rays to the Project,
change the Maximum Ray Length to 20 mm, and click OK.
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37. Start the analysis by choosing Analysis > Begin Analysis.
38. The 3D rays illustrate the refraction of the center lens. In order to get a better view of them, turn
off the mesh view of the TIR surface and the exit surface by selecting them and changing Display
Mesh under Section/Profile in the property control to No.

Because the refracted rays are hitting the shaft of the exit surface and are not directed straight down, we
can see that the center lens is not refracting the light enough. In order to refract the light more, we will
increase the curvature of the center lens.
39. Deselect current selections if any, and then click on the exit surface profile to select it.
Reflector Design View, change the Angular Extent of the End section to -150 degrees.
40. Run the analysis again.

In
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Most of the refracted rays are now closer to straight down, but one set of rays is refracted too much. A
non-spherical lens would be necessary to perfect this outcome, but we should be able to reach the beam
angle goal even with a spherical lens. We can still use this curvature to get most of the refracted light to
be directed straight down. The overall results may be acceptable, so we can now check what the output is
when we use the LED rather than the theoretical laser array. Note that since the relative source size of
the LED is not a perfect point source, this could likely mean that an ideal non-spherical center lens would
not improve the beam angle anyway.

Design Results
41. Under Settings > Layers, turn off all of the laser layers and turn on all of the LED layers. Note
that there are now several RAY layers and some of the LED layers are listed after all of the RAY
layers.
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42. Under Analysis > Specify Raytrace Settings, change the number of Initial Source Rays back to
2,500,000 and the Number of Ray Reactions back to 25. Under the Display tab, un-check Add 3D
Rays to Project.
43. Run the analysis.
44. Open the Photometric Report under View > Photometric Report. Towards the bottom of the
report is the Full Beam Angle.
The full beam angle is close to 7.5°, which is less than the beam angle goal of 10° for this design. Even
though the center lens used a spherical curve, which we found was not necessarily ideal for a very small
beam angle, we were still able to achieve an angle smaller than the beam angle goal. We will need to
increase the beam angle to get closer to the beam angle goal of 10°, but it is a good idea to check other
results as well to see if there are other adjustments we might also need to make.
45. View other output such as the Shaded Illuminance Plot and the Polar Candela Plot (under the
View menu).
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Looking closely at the shaded illuminance plot, there are two extra rings in the pattern that may be
undesirable. The wide outer ring is due to some light that misses both the TIR surface and the center
lens, and so it comes out through the exit surface at a higher angle than desired. Even though we
designed to account for this effect, we had designed around a perfect point source. Since the actual LED
has a larger relative source size than a point source, this extra ring of light appears. To work on removing
this ring, we could try making the center lens wider to capture the missed light, so that it starts to the right
of the diagonal construction line. However it is a rather subtle problem since its edges fade rather
smoothly, and so we will not take the steps to attempt to remove this ring in this tutorial.
The second ring, which is thinner and closer to the center of the pattern, may be more of a noticeable
issue because it has a somewhat sharp outer edge rather than a faded edge. The cause of this ring is
also due to the larger relative source size of the LED. The source size, relative to the optical surfaces, is
large at the start of the TIR surface profile since that is the closest optical surface to the LED. That
surface aims totally internally reflected light straight downward, but some of the light does not reflect at the
perfect angle and is intercepted by the shaft. The light that hits the shaft totally internally reflects and then
exits at an unwanted angle, creating the ring in the pattern. To work on removing this ring, we can re-aim
the start of the TIR profile in order to avoid interaction with the shaft. At the same time, we can attempt to
widen the beam angle to get closer to the beam angle goal.
46. Deselect current selections if any, and then click on the TIR surface profile to select it. In
Reflector Design View, locate the Aiming of Sections dialog box in the upper left of the window.
Enter 14(1)0 for aiming angles by direction, and then click Update Aiming. (Note that this aiming
angle range was found by iterating through various ranges to find the best resulting beam angle
and illuminance pattern.)
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47. In Reflector Design View, change the Weight Adj. of the End section to 0.3 to lessen the intensity
of the center of the spot. For an in-depth explanation of this design technique, see Beginner
Tutorial 3: Design a Revolved Reflector.

48. Since the TIR surface has now become too large, find Extent under Start & Extent in the property
control and change it to -55 degrees. This new extent keeps the collimator size within the
constraints, which you can again check by hovering your mouse over the end of the TIR profile.
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49. Since the TIR profile extent has changed by 5°, use Modify > Rotate to rotate the diagonal
construction line 5° around 0,0 to update its illustration of the border line of light that hits the TIR
surface.

50. Select the Exit surface and adjust the Lengths of the profiles according to the new start location
and construction line angle. Use Length values of 7.8 for the Start section and 11 for the second
section.
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The center lens is no longer exactly aimed as was intended since it now covers a slightly larger range of
angles. However, the change is slight and there is a small amount of allowable variance in the curvature
of the center lens, so we may not have to re-adjust the aiming.
51. Run the analysis and view the output data again.

The ring that we attempted to remove is no longer visible, and the full beam angle is now within 1° of the
beam angle goal, 10°. The illuminance pattern looks decent and all the design parameters have been
met. As an extra bonus, the design and material of the collimator produces an optical efficiency in the
high 90’s, as can be seen in the Photometric Report.
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