Beginner Tutorial 3 – Designing a Revolved Reflector with the Parametric
Optical Design Tools
This tutorial will lead you through the process of creating a round symmetric downlight that achieves a
particular candela distribution. The design will have the following parameters:






Use a 70W ceramic metal halide lamp
6" diameter opening
1.2" diameter hole for the lamp
Have a 45 cutoff angle to the center of the arc tube
Make as wide a beam as possible with as even of an illuminance pattern as possible

Overview of Design Process
This tutorial will use the Revolved reflector tool. This and the other design tools are premised on the idea
that the final desired candela distribution is the result of a reflector that aims the right amount of light
toward each angle within the distribution. Therefore, the problem that needs to be solved is determining
the portion of the reflector that is aimed toward each angle in the distribution. The Parametric Optical
Design Tools facilitate the design process by creating optics comprised of multiple sections, with each
section aimed at an angle within the limits of the distribution. Each reflector section is then linked to a
weighting factor that determines the size of the section, the size being defined as some fraction of the total
area allocated for the reflector.
The process begins by first specifying some general parameters about the optic, including:
1. The construction plane in which the 2D profile of the design will be created
2. The lamp position within the construction plane
3. The start location of the reflector profile (either end can be used as the start location)
4. The total angular extent of the reflector (this is generally an estimate at the beginning of the
process)
5. The angular limits of the designed beam pattern
Given this general information, Photopia will create a 3D optic comprised of multiple sections, each aimed
at different angles within the desired beam limits. The number of sections (or the angular steps between
the aiming angle for each section) is defined by the user. Different candela distributions are created by
changing the weighting factor (and thus the size) of each reflector section. If a particular angle has too low
of a candela value, then we can increase the amount of reflector aimed toward that angle. If an angle has
too high of a candela value, then do the opposite. The final determination of the weighting factor
distribution is reached by trial and error.
The designer quickly learns the dependence of the candela values on the various weighting factors seeing
how light aimed at one particular zone influences neighboring zones as well. If the lamp were a true point
source, then the zones would act independently and the weighting factors could be pre-determined via a
relatively simple process. But since all real sources have some physical extent, the weighting factors
cannot be accurately pre-determined. The designer can also use non-specular materials in the parametric
based design. In this case once again, changing the weighting factor for one zone now influences several
other zones because of the added spread of the reflected light. But even in this case, the designer quickly
sees the interdependencies and can adjust the weights accordingly to move toward the desired goal.
In order to aid the process of defining weighting factors, Photopia includes an automated way of defining a
set for a given reflector. The automatic weighting factors are calculated from a relatively general and
flexible equation that provides useful trends for lighting distributions. For example, in the downlight to be
designed in this tutorial, the candela distribution will have its peak at a vertical angle that will likely be
between 30 and 40. This means that the reflector is most likely to direct more light toward these higher
angles in the distribution than it does toward the angles around the beam center. The weighting factors
should reflect this fact by growing to larger values along with the vertical angle in the candela distribution.
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So the equation that Photopia uses accommodates this by calculating weighting factors as a function of
the angle away from the beam center. The rate at which the factors grow with the angle is determined by
one of the coefficients of the equation. It is helpful to use the calculated weighting factors because they will
change smoothly through the distribution and smoothly changing weighting factors generally means a
smoothly changing reflector and thus a smoothly changing candela distribution.

Starting the Project
The best way to see how these tools work is to go through a real project.
1. Begin by starting Photopia and selecting File > New.
2. If the units are not already in inches, then change them to inches by selecting Settings > Project
Settings and selecting Inches from the Length Units setting.
We will create the 2D profile of the reflector in the world XZ plane (the front view) so that the beam is
directed toward the –Z axis in Photopia’s World Coordinate System (WCS). The WCS is the coordinate
system that is referenced to the photometric coordinate system described in Beginner Tutorial 2. 2D
entities such as the reflector profiles from the Parametric Optical Design Tools, arcs and circles can be
created in any plane by using a Construction Plane (CPlane). CPlanes define local XY planes similar to
sketch planes in 3D solid modelers or AutoCAD’s UCS. They behave the same as the CPlanes in the
Rhino CAD software.
3. To create a CPlane in the front view, right click your mouse in the CAD view and select Standard
Views > Front View from the pop-up menu.
When a standard view is chosen, the CPlane automatically changes to the chosen view. The CPlane is
illustrated with a grid and a red line indicating the X-axis and a blue line indicating the Y-axis. The grid
parameters can be changed under the CPlane tab of Settings > Project Settings on the main menu.
More details on Photopia’s CAD system are provided in Chapter 4 of the User’s Guide.

Importing the Lamp
Add the lamp to the project with the following steps:
4. Select File > Import Lamp from the main menu. Select the CMIT70.LAMP file from the lamp
library.
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5. Press Enter to accept the default lamp insertion point of 0,0.
6. Zoom out by right clicking your mouse and selecting Zooming > Zoom Out or just click on the
Zoom Out button on the toolbar. Now that you see where the various zooming options are, the
rest of this tutorial will simply say to perform a particular zoom but not provide details of how to
navigate the menu.
7. Save the project by selecting File > Save As from the main menu, naming the project Spotlight
MH70W.

Define the Reflector
Create the parametric reflector with the following steps:
8. Select Design > Reflector: Aiming Based > Revolved from the main menu.
a. Accept the default lamp center point by pressing Enter.
b. Enter 3,-3 as the start point for the reflector. Remember this coordinate is in the CPlane.
See the coordinate readout in the lower left portion of the screen as you move your
mouse around the CPlane.
c.

Drag your mouse and pick (left click) an angle like that shown in the picture to define the
total extent of the reflector. This angle will be an estimate at this point. We will be able to
change this angle and define it more precisely once we see the general shape of the
reflector.
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d. Accept the default aiming angle of -45 for the first reflector aiming section. The negative
sign tells Photopia this is an angle to the left of nadir and 45 is the high angle in the
candela distribution.

e. Accept the default aiming angle of 0 for the last reflector aiming section. This is the
aiming angle for the most central part of the reflector.
f.

Enter an aiming angle increment of 2.5. This will be the change in aiming angle between
the different sections of the reflector.

g. Enter 180 for the number of revolve segments. This is the number of segments that will
be used around the circumference of the reflector. Since this reflector is assumed to be
smoothly spun, we are using a relatively high number.
After the last item is entered the 3D reflector will be created. If you select the reflector by picking it in the
CAD view you will see the properties you entered illustrated graphically in the CAD view and numerically in
the property control at the right of the screen. You can change any of the values in the property control to
modify the reflector. The reflector should look like the one in the following image.
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The cyan colored lines in the reflector illustrate the aiming directions and extents of each reflector section.
The default reflector is based on default coefficients for the equation that calculates the weighting factors.
Before we test the performance of this design, we can first refine our definition of the total angular extent
of the reflector now that we see its general shape.
9. With the reflector selected so that the aiming lines and other geometrical parameters are
displayed, use the zoom by window to zoom in on the upper part of the reflector. Once zoomed in,
you can see that the reflector extent goes beyond what may be desired. To allow room for the
lamp socket, the hole diameter may need to be at least 1.2".
10. We can now enter a new value for the Extent in the property control to make the top end of the
reflector end at a radius of about 0.6". Type in a value of 112 for the Extent and then press Enter.
You will see the reflector be recreated to the smaller size. Now zoom back out with a zoom
extents.

Setup the Raytrace
One other step we need to do before we can analyze the design is assign a material to the reflector. The
reflector was created on a new layer named “REFL-Main”.
11. Select Edit > Design Properties and go to the Reflective tab.
12. Click on the REFL-Main layer and then click on the Assign Materials button. Select the M.A.K.
specular clad aluminum material (MAKSP001) for this reflector. We will assume a specular
reflector during this design tutorial. The click OK on the Material Selection screen and OK again
on the Design Properties screen.
We can now set the photometric output and raytrace settings. The following section will provide the
necessary data to enter but please see Tutorial 2 for details about the meaning of all of the options.
13. Select Analysis > Specify Photometric Output.
14. Specify output types of Photometric Report and Illuminance on a Plane.
15. In the Photometric Report tab, specify an Indoor report with Type C photometry using a horizontal
angle set of 0 only (since the design is symmetric) and a vertical angle set of (0(5)90).
16. Retain the Test Distance of 20 feet and set the Photometric Center at 0, 0, -3.
17. Change the Luminous Dimensions so that they have a Z value of 0.
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18. In the Illuminance tab specify one plane that is 20’ x 20’ and 8’ below the luminaire. Note that the
corner point coordinates in the screen below are specified in feet. Close the Photometric Output
Specification screen when done.

19. Select Analysis > Specify Raytrace Settings. Enter 500,000 rays for Initial Source Rays so that
you can quickly go through iterations while in the design phase. Leave the Number of Ray
Reactions at the default value of 25.
20. Go to the Display tab and change the Update Frequency to 100%. This design will analyze
relatively quickly and it is convenient to see only one update so that you can see the final effects
of new weighting factors compared to the previous weighting factors when the analysis is
complete. Close the Raytrace Settings screen.

Analysis Results & Design Iterations
We are now ready to analyze this reflector design. Once we see the results we can make a decision about
how to alter the weighting factors to try and improve the design.
21. Select the reflector if it is not already selected. You can tell when it is selected because it will be
highlighted in light red and show the aiming lines. Next select View > Parametric Optical Design.
This will open a special view that displays the weighting factors for each zone superimposed onto
the candela distribution.
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22. Start the calculations by clicking on the calculator icon on the toolbar. After a minute or so you will
see the candela plot presented in the view showing the weighting factors. You will see that the
default design produces a large spike in the beam center.

These results provide our first feedback on how we should alter the weighting factors to improve the
design. Since we have far too much light in the center of the distribution, we should change the weighting
factors in this area. We can do this a few different ways.


We can change the coefficients of the weighting factor equation so that a different curve with
lower weights around 0 is created.



We can turn off the automatic weighting factors and type in values manually.



We can type in Weight Adjustment values to alter the default values.

We will use the last method listed, changing the Weight Adjustment values. We don’t know by how much
to adjust the weight at 0 and we don’t know if we need to adjust the weights up to -10 as well. But since
we can see the results of our changes relatively quickly, we can simply try some ideas and see their effect.
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When changing weights or other parameters of the design in an attempt to improve performance, it is
recommend that you change only one variable at a time. This allows you to isolate the effects of each
variable and it makes it easier to understand which variables you need to change in future variations.
A good way to begin making changes if you aren’t sure of the magnitude of the change is cut the current
value in half if you are looking for a decrease or double it if you are looking for an increase. If you
undershoot or overshoot your goals then it is relatively easy to keep halving or doubling your weight until
you achieve your goal.
23. So we will apply a Weight Adjustment of 0.5 to the weighting factor at 0. After the weighting factor
plot updates showing the new values, the reflector will have also been regenerated.

24. Click the calculator icon to see how this new design performs.
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The results shown above illustrate the improvement, as we did decrease the spike in the center of the
distribution. But the spike that remains is still too large.
25. So we will cut the weighting factor at 0 in half once again by entering a Weight Adjustment of
0.25.

26. Since we still have too much light at 0°, we will simply remove the weighting factor at 0 by making
the Weight Adjustment 0.

There is still too much light in the center of the distribution, so we may need to adjust the weighting factor
at more than just 0°.
27. This time we will enter a Weight Adjustment of 0.5 at -2.5°.

28. Cut the weighting factor at -2.5 in half once again by entering a Weight Adjustment of 0.25.
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29. Since we still have too much light in the center, we will simply remove the weighting factor at 2.5
by making the Weight Adjustment 0.

The spike is looking wider now, so we will try slowly adjusting the weighting factors at higher angles.
30. Enter a Weight Adjustment of 0.75 for 5°.

This change looks much better, but there is still a slight peak at slightly higher angles. We will continue to
slowly bring the weighting factors down.
31. Enter a Weight Adjustment of 0.75 for 7.5°.
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32. Enter a Weight Adjustment of 0.75 for 10° for one last refinement to smooth out the slight peak.

This design now looks good.
33. Select File > Save from the main menu.
Now that we have a refined design, run it with more rays to view more accurate results.
34. Choose Analysis > Specify Raytrace Settings to set the initial Source Rays to 2,500,000, and
run the raytrace again.

35. Check the appearance of the illuminance plane by selecting View > Illuminance > Shaded Plot.
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The shaded illuminance plot shows a very smooth and uniform beam with a sharp cutoff; the only issue is
a shadow from the lamp's arc support. One way to smooth out issues around the circumference of the
light pattern is to add facets around the circumference of the reflector. Circumferential facets will add
circumferential spread to allow overlap into the shadowed area. However, facets that are too large will add
a spokes to the light pattern, so we still want to keep a relatively large number of facets.
36. Click the reflector in CAD view to select it. Under the Extrude/Revolve section in the property
control, change the Num Segments to 72. Run the raytrace.
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The shadow has improved but is still stands out, and some spokes have appeared in the pattern as well. A
lower number for the Num Segments parameter would allow larger facets and would cause the shadow
issue to improve further, but the spokes would become even more apparent. Another way to smooth light
patterns is to use a semi-specular material.
37. Under Edit > Design Properties > Reflective, change the material for the REFL-Main layer to
Foremost 3002 LI. Run the raytrace.
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This type of reflector is one that is relatively difficult to design. Yet we finished the design just a few
iterations that took no time to draw and less than a minute each to calculate. This is the power of the
Parametric Optical Design Tools: to be able to manipulate your design geometry based on meaningful
optical parameters with as little effort as possible. But you also get a bit more out of designing optics this
way. You can tell from the small adjustments we were making in the weighting factors that the difference
between an acceptable design and a poor design was small. If you were watching the reflector geometry
update as you changed the weighting factors, you would have seen that the changes in the shape were
never very large. Furthermore, all of the changes we made were very near the center of the distribution.
This tells you as the designer of this optic that the central part of the reflector is the most critical. You also
can learn from this example that this is a very sensitive design. Not only is the design sensitive to small
changes in the reflector geometry but it is also likely to be sensitive to small changes in the lamp position.
You can experiment with this by simply clicking on the lamp and changing its Z coordinate to a new value.
Given the knowledge gained about this reflector, you can make appropriate decisions about how you
might want to modify the design in some way to help minimize its sensitivities. You might have noticed in
the Parametric Optical Design View that each reflector section has its layer listed. You can change the
layer of each section as you desire. You can then assign different materials to different layers. Thus, you
can work with optics that use several material finishes.
When you are finished with your design, you can export the 2D profile of it to a DXF or DWG CAD file that
can be imported into most any CAD package. You can then create your 3D mechanical models based on
the curve created by Photopia. You can set the angular resolution of the exported curve to any degree (as
measured from the lamp location) depending on the needs of your CAD software or toolmaker.
You can learn more about the details of all of the options in the Parametric Optical Design Tools in
Chapter 4.
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