
Beginner Tutorial 4 – Designing a Fresnel Lens with the Parametric Optical 

Design Tools 

This tutorial will lead you through the process of creating a round prismatic lens, referred to as a Fresnel 
lens. The design will have the following parameters: 

 Use a narrow beam LED source 

 Acrylic for the lens material 

 50mm diameter lens 

 3mm minimum lens thickness 

 Be designed to make as narrow a beam as possible   

After designing the lens as defined above, we will investigate the different functions of the lens tool that 
allow us to make quick adjustments to the design’s parameters. These are the changes we will make to 
the lens: 

 Change the diameter from 50mm to 60mm 

 Change the location of prisms from only the outside surface to both outside and inside surfaces to 
only the inside surface 

 Use pull direction and draft angle to make the prisms mold-able 

 Add fillets to the prisms 

 Change from a stepped profile type to a smooth profile type 

Overview of Design Process 

This tutorial will use the Revolved lens tool. The light distributions of the lens tools are controlled via the 
same aiming angle and weighting factor concept used for reflectors. The general concept behind the lens 
tools is to create a prismatic surface, with the prisms “mapped” to a profile (base profile), which is the 
general shape of the lens. The aiming and weighting factors simply dictate the number of prisms aimed 
toward each angle in the distribution. Since there are two surfaces required for a lens, an inside surface 
into which the light enters the lens, and an outside surface through which the light exits the lens, the base 
profile is used for one of these surfaces and the prisms are mapped to a second surface, offset from the 
first. 

The process begins by first specifying some general parameters about the optic, including: 

1. Whether the lens will be revolved, extruded and mirrored (symmetric), extruded and not mirrored 
(asymmetric) or extruded along a path 

2. The base profile to which the prisms will be mapped 

3. The lamp location 

4. The aiming specifications given by the aiming angle for the start of the base profile, the end of the 
base profile, and the aiming angle increment 

5. The material index of refraction 

6. The number of prisms to be used in the lens 

7. Parameters specific to the revolved or extruded surfaces 

Given this general information, Photopia will create a 3D lens comprised of multiple aiming sections of 
prism steps, each aimed at different angles within the desired beam limits. The number of sections (or the 
angular steps between the aiming angle for each section) is defined by the user. Different candela 
distributions are created by changing the weighting factor (and thus the number of prisms) of each aiming 
section. The process of weight adjustment to create a smooth light pattern is identical to that of a reflector, 
which is covered in Beginner Tutorial 3. In this tutorial, we will use only one aiming section (by aiming all 
prisms to 0°) and focus on parameters that are specific to lenses. 
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Starting the Project 

The best way to see how the lens tool works is to go through a real project.  

1. Begin by starting Photopia and selecting File > New.  

2. If the units are not already in millimeters, then change them to millimeters by selecting Settings > 

Project Settings and selecting Millimeters from the Length Units setting. 

We will create the 2D profile of the reflector in the world XZ plane (the front view) so that the beam is 
directed toward the –Z axis in Photopia’s World Coordinate System (WCS). The WCS is the coordinate 
system that is referenced to the photometric coordinate system described in Beginner Tutorial 2. 2D 
entities such as the lens profiles from the Parametric Optical Design Tools, arcs and circles can be 
created in any plane by using a Construction Plane (CPlane). CPlanes define local XY planes similar to 
sketch planes in 3D solid modelers or AutoCAD’s UCS. They behave the same as the CPlanes in the 
Rhino CAD software.  

3. To create a CPlane in the front view, right click your mouse in the CAD view and select Standard 

Views > Front View from the pop-up menu.  

When a standard view is chosen, the CPlane automatically changes to the chosen view. The CPlane is 
illustrated with a grid and a red line indicating the X-axis and a blue line indicating the Y-axis. The grid 

parameters can be changed under the CPlane tab of Settings > Project Settings on the main menu. 
More details on Photopia’s CAD system are provided in Chapter 4 of the User’s Guide. 
 

Importing the LED 

4. Select File > Import Lamp from the main menu. Select the W49180.LAMP file from the folder to 
choose the Seoul Z-Power 90 deg. 

 
 

5. Press Enter to accept the default lamp insertion point of 0,0.  

6. Zoom out by right clicking your mouse and selecting Zooming > Zoom Out or just click on the 
Zoom Out button on the toolbar.  

7. Save the project by selecting File > Save As from the main menu, naming the project Fresnel 
Lens.  
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Define the Lens 

Create the parametric lens with the following steps: 

8. Select Design > Lens > Revolved from the main menu.  

a. Press Enter to accept the default of a polyline base profile.  

b. Press Enter to accept the default lamp center of 0,0 since this is where the LED is 
located. 

c. Enter 0,-50 as the start point for the base profile. Remember this coordinate is in the 
CPlane. See the coordinate readout in the lower left portion of the screen as you move 
your mouse around the CPlane.  

d. Enter 25,-50 for the next base profile point to make a 50mm diameter lens. 

e. Press Enter again to end the base profile. 

 
 

f. Press Enter to accept the default number of prism steps of 10. If the prisms end up being 
too large or too small, we can later change this value in the property control. 

g. Press Enter to accept the default index of refraction of 1.491, for acrylic. This value can 
also be changed in the property control if you want to use a different material. 

h. Enter 0 for the aiming angle of the start of the profile. 
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i. Enter 0 again for the aiming angle of the end of the profile. This angle range will allow the 
smallest possible beam size for our setup. 

j. Since the aiming range is from 0 to 0 degrees, the aiming angle increment value is not 
used. Simply press Enter to accept the default of 5 degrees. 

k. Press Enter to accept the minimum thickness of 3mm. This will be the distance between 
the base profile and the prism valleys. 

l. Enter 180 for the number of revolve segments. This is the number of segments that will 
be used around the circumference of the lens. Since this lens is assumed to be smoothly 
spun, we are using a relatively high number. 

 
 

After the last item is entered the 3D lens will be created. If you select the reflector by clicking it in the CAD 
view you will see the properties you entered illustrated graphically in the CAD view and numerically in the 
property control at the right of the screen. You can change any of the values in the property control to 
modify the lens, which we will go over next. The lens should look like the one in the following image. 

 
 

The cyan colored lines in the CAD view illustrate the aiming directions of each prism step.  

9. Right click in CAD view, and then choose View Style > Show Surface Orientation. 

10. Rotate your view by right clicking in CAD view, and then choosing Dynamic Views > Orbit. 
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To view the profile a little more clearly, make the mesh invisible while still allowing the lens to participate in 
calculations. 

11. Go back to front view by right clicking in CAD view and choosing Standard Views > Front View. 

12. Under Display in the property control at the right of the screen, change the Display Mesh value to 
No. 
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Adjust the Lens Properties 

A major advantage of the Parametric Optical Design Tools is how quickly we can change simple 
properties and watch the entire optical design update automatically. We will now go over some of the 
useful ways you can change the Fresnel lens that we just created. 

The first parameter that needs to be changed is the Offset Style, located under Offset Profile in the 
property control to the right of the screen. The default option is Radial from Lamp Center, which means 
that the prisms are mapped to a profile that is offset from the base profile in a radial direction from the 
lamp center. Using this option, the outside of the lens is actually bigger in diameter than the inside of the 
lens. However, we want a lens that is 50mm in diameter, so we need to choose a different offset style if 
we want the outside of the lens to be the same diameter as the inside of the lens.  

13. Under Offset Profile in the property control, change the Offset Style from Radial from Lamp 
Center to Simple Offset. 

 
 

Now, when you hover your mouse in CAD view and read the coordinates in the lower left part of the 
screen, you can see that both the inside and outside lens profiles now extend 25mm from the center, or 
50mm in diameter. 

We created the lens to be 50mm in diameter, but now we want it to be 60mm in diameter to fit in a 
different housing. This means that we need to change the length of base profile, the profile to which the 
prisms are mapped. 

14. If the lens is not still selected, click on it in the CAD view to select it. 

15. Choose View > Parametric Optical Design and click on the Base Profile Properties radio button, 
which is right above the table of values. 
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In this screen, you can see the angle, length, and angular extent of each section of the base profile. Our 
base profile has only one section, and so a single line of values appears in the table. Changing the angle 
of the section will rotate that section, and an angle of 0° is the direction of the positive x-axis. Giving the 
angular extent a non-zero value will make that section an arc with whatever angular extent you enter. 
Changing the length of the section is the parameter that we want to change, since in our case, the length 
of this base profile section is the radius of our entire lens. 

16. Change the Length of the base profile section from 25 to 30 to make our lens 60mm in diameter. 

 
 

You can see that the lens design has updated. There is still the same number of prisms with the same 
aiming, but they are spread over a slightly larger lens. 
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The optical design is currently being controlled by prisms on the outside of the lens. If the design is also 
controlled by prisms on the inside of the lens as well, the outside prisms will be less steep because they 
will be doing less optical work. Shallower prisms may allow for less variance in prism thickness, which will 
make the part easier to mold. 

17. Select the lens if it is not selected, and then find the % of Control Inside parameter under Optical 

Parameters the property control. Change the value from 0 to 50. 

 
 

We now have prism steps on both lens surfaces, but there are some undercuts on the prism risers on the 
inside of the lens. Since a mold cannot pull upward to create this shape, we need to add a pull direction 
constraint. 

18. Find the Use a Pull Direction parameter under Tooling Constraints in the property control and 
change its value to Yes. 

19. To make a pull direction upward, enter 1 in the Pull Direction Y parameter, since the positive y 
direction in the current CPlane is the direction we want to be able to pull the mold. 
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Notice the prism profile has updated and there are no longer undercuts in the design. The default Draft 

Angle (under Tooling Constraints in the property control) of 1° is appropriate for our design, but you may 
change this value as well. 

Now we want to alter the design so that it has a flat outer surface that can easily be cleaned. We can 
utilize one of the parameters that we have already looked at by taking it further, the % of Control Inside 
parameter. 

20. Under Optical Parameters in the property control, change the % of Control Inside value to 100. 
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All the optical control is now on the inside of the lens, and our pull direction constraint has been retained. 

During the design process we have been aware of manufacturing constraints to make sure that our new 
lens is mold-able. There is another parameter that will make our design even closer to what will actually 
be manufactured: fillets. 

21. Under Tooling Constraints in the property control, change the Peak Fillet Radius to 0.3 and the 
Valley Fillet Radius to 0.3. 

 
 

22. Zoom in to view the fillets by right clicking in the CAD view and choosing Zooming > Zoom 

Window. 
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Now we want to make a smooth, convex lens rather than a lens with prismatic steps, but we want the 
same aiming parameters. This is a simple change in Photopia using the Profile Type parameter. 

23. Under Optical Parameters in the property control, change the Profile Type from Stepped to 
Smooth.  

 
 

To use a finer resolution on the profile curve, we can adjust the Number of Curve Segments, which is a 
guideline for the number of aimed refractor surfaces the lens profile creates. Note that this value is 
equivalent to the number of prism steps for a stepped profile type. 

24. Under Tooling Constraints in the property control, change the Number of Curve Segments to 20 
for a finer profile curve resolution. 



 12 Beginner Tutorial 4 – Design a Fresnel Lens 

 

 
 

25. To change the lens from a convex-plano to a plano-convex, change the % of Control Inside under 

Optical Parameters from 100 to 0. 
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26. To make the lens bi-convex, change the % of Control Inside to 50. 

 
 

Notice that our original minimum thickness of 3mm is now being overridden by the Offset Distance (under 

Offset Profile in the property control). In this case, the Offset Distance is the maximum thickness since 
the largest thickness of the lens occurs at the profile start. Since the Offset Distance had automatically 
increased for the covex-plano and plano-convex lenses, it is now set to a higher value than necessary. In 
order to utilize the Minimum Thickness parameter instead of the Offset Distance parameter, we can 
“reset” the Offset Distance by entering a value of 0. Then the Offset Distance will automatically adjust to 
what it needs to be for the Minimum Thickness value to be prioritized. 

27. With the lens selected in CAD view, enter 0 for Offset Distance under Offset Profile in the 
property control. 
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We can also make a custom inside surface by changing the base profile properties, and the lens will 
automatically update to retain the aiming properties. Say that we want the inside surface to be a cone and 
the outside surface to be convex and control the light direction. 

28. Change the % of Control Inside back to 0 as in step 25. 

29. Open the Parametric Optical Design View again by choosing it under the View menu. Choose the 
Base Profile Properties radio button. 

 
 

30. Change the Angle of the base profile’s single section from 0° to 10° to make the inside surface 
into a cone. 



 15 Beginner Tutorial 4 – Design a Fresnel Lens 

 
 

The inside surface is now a custom shape, but there is now a hole in the outside surface. 

 
 

This problem is originating from the Offset Style. Since we are currently using Simple Offset, the base 
profile at a 10° tilt is offsetting perpendicularly and the offset profile is built from there, creating a hole in 
the center of the lens. We can change the Offset Style back to Radial from Lamp Center in order to use an 
offset profile that starts in the center of the lens. 

31. Change the Offset Style under Offset Profile from Simple Offset to Radial from Lamp Center.  



 16 Beginner Tutorial 4 – Design a Fresnel Lens 

  
 

Changing other base profile properties by adding more sections and by using the Parametric Optical 
Design View allows you to build any custom surface as one lens surface while Photopia automatically 
builds the other surface to control the light directions. 

You can see that when designing a lens in Photopia, it is very simple and quick to change any of several 
parameters. Almost all of the instantaneous changes we made would take a substantial amount of time 
and effort to design without the Parametric Optical Design Tools. This is the power of the Parametric 
Optical Design Tools: to be able to manipulate your design geometry based on meaningful optical and 
mechanical parameters with as little effort as possible.  

You can learn how to run the design simulation and view the analysis results in Beginner Tutorial 3. When 
you are finished with your design, you can export the 2D profile of it to a DXF or DWG CAD file that can 
be imported into most any CAD package. You can then create your 3D mechanical models based on the 
profile created by Photopia.  

You can learn more about the details of all of the options in the Parametric Optical Design Tools in 
Chapter 5.  


